Indicators not working as should with my new Swift

ROBERT C PATTISON replied on 19/08/2019 17:11

Posted on 19/08/2019 17:11

Hi

I have a BMW X3 2009. I was informed that my hazard lights on the Swift van(2019) was pulsing whilst driving. On checking further i noted that my indicators were going really fast. I was informed by my caravan agent that i needed a VLM board fitted from Sergent of Beverley(they make the Command units and trackers for Swift Caravans). On fitting this i noted that with the ignition only on every thing works fine. However once i switch the engine on i get no indicators - those they are still flashing normally on the car. I am aware that my towbar is factory fitted and does not have a fridge/auxillary battery fitted in the loom. Does this make a difference. Any suggestions would be very useful as it appears to have everyone baffled.

Would a new UK loom fitted solve the problem or is it the caravan?

Bob Pattison

viatorem replied on 19/08/2019 17:43

Posted on 19/08/2019 17:43

There's a VLM A and B board depending on the age of your BMW A for early B for later beemers, I can't find any dates but maybe yours is A ?

ROBERT C PATTISON replied on 20/08/2019 12:38

Posted on 20/08/2019 12:38

Thanks for the reply. Sargent test 2 different boards- still same problem. They stated it was to do with no fridge/ auxiliary battery charge in the loom. This baffled me surely this would not stop indicators working ?

ROBERT C PATTISON replied on 20/08/2019 21:17

Posted on 20/08/2019 21:17

Oh yes - that desperate to find a solution. Also different people use the sites hence cover all basis.

I tried car on another new caravan at dealers without VLM board - responded same as original = pulsing hazard on all time. Indictors very fast  - though working. I have also tried car on friends caravan (2017) only difference was his lights are bulbs - not LSD - worked fine.  

JVB66 replied on 20/08/2019 21:31

Posted on 20/08/2019 21:17 by ROBERT C PATTISON

Oh yes - that desperate to find a solution. Also different people use the sites hence cover all basis.

I tried car on another new caravan at dealers without VLM board - responded same as original = pulsing hazard on all time. Indictors very fast  - though working. I have also tried car on friends caravan (2017) only difference was his lights are bulbs - not LSD - worked fine.  

Posted on 20/08/2019 21:31

That sounds like the problem that raised its head when led lighting was first introduced, some cars did not recognise the low power of leds on caravans and "thought"it was a bulb failure  ,I thought that the caravan manufacturers had it "sorted", I think some sort of resister was fitted to "fool" the cars lighting supply

lornalou1 replied on 23/08/2019 15:03

Posted on 20/08/2019 21:17 by ROBERT C PATTISON

Oh yes - that desperate to find a solution. Also different people use the sites hence cover all basis.

I tried car on another new caravan at dealers without VLM board - responded same as original = pulsing hazard on all time. Indictors very fast  - though working. I have also tried car on friends caravan (2017) only difference was his lights are bulbs - not LSD - worked fine.  

Posted on 23/08/2019 15:03

perhaps thats the problem as LSD is a hallucinogenic and everything will flash after taking. winkwink(sorry)